summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2364a2b2b919
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Dct Mei <dctxmei@gmail.com>
+
+pkgname=qv2ray-plugin-trojan
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Qv2ray Plugin: Trojan"
+arch=('x86_64')
+url="https://github.com/Qv2ray/QvPlugin-Trojan"
+license=('GPL3')
+depends=('boost-libs' 'openssl' 'qt5-base' 'qv2ray')
+makedepends=('boost' 'cmake' 'git' 'libffi' 'ninja' 'qt5-tools')
+groups=('qv2ray-plugin')
+source=("$pkgname-$pkgver::git+$url.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ mkdir -p build && cd build
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DFORCE_TCP_FASTOPEN=ON \
+ -GNinja
+ ninja
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/build/"
+ install -Dm 644 libQvTrojanPlugin.so -t "$pkgdir/usr/share/qv2ray/plugins/"
+} \ No newline at end of file