summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index abfef24b166b..0ccb0260194d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
# Maintainer: justforlxz <justforlxz@gmail.com>
pkgname=qwlroots-git
-pkgver=r227.6c575f0
+pkgver=r232.dd9c126
pkgrel=1
pkgdesc='Qt and QML bindings for wlroots.'
arch=('x86_64' 'aarch64')
url="https://github.com/vioken/qwlroots"
license=('Apache' 'GPL2' 'GPL3' 'LGPL3')
depends=()
-makedepends=('git' 'wlroots' 'ninja' 'wayland-protocols' 'wlr-protocols-git')
+makedepends=('git' 'wlroots' 'ninja' 'wayland-protocols' 'wlr-protocols')
provides=('qwlroots')
-source=("$pkgname::git+https://github.com/vioken/qwlroots")
+source=("git+https://github.com/vioken/qwlroots")
sha512sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd qwlroots
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
build() {
- cd $pkgname
+ cd qwlroots
cmake -B . -G Ninja -DCMAKE_INSTALL_PREFIX=/usr
cmake --build .
}
package() {
- cd $pkgname
+ cd qwlroots
DESTDIR="$pkgdir" ninja install
}