summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6f5c3c21f8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=abind
+_cranver=1.4-5
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-abind
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Combine Multidimensional Arrays"
+arch=('any')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('LGPL')
+depends=('r' )
+
+
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('136f981e1c4f618b64a87faaa7797c97')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+