summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c9f9c029056
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=AnnotationForge
+_pkgver=1.38.0
+pkgname=r-${_pkgname,,}
+pkgver=1.38.0
+pkgrel=1
+pkgdesc='Tools for building SQLite-based annotation data packages'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-biobase
+ r-biocgenerics
+ r-dbi
+ r-rcurl
+ r-rsqlite
+ r-s4vectors
+ r-xml
+)
+optdepends=(
+ r-affy
+ r-biocfilecache
+ r-biocmanager
+ r-biocstyle
+ r-biomart
+ r-biostrings
+ r-genomeinfodb
+ r-go.db
+ r-hgu95av2.db
+ r-homo.sapiens
+ r-httr
+ r-human.db0
+ r-knitr
+ r-markdown
+ r-org.hs.eg.db
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('e8fffd592a364e0154c255964cbfd198b6f6f6b227c83ca4f4efa9d69b722ca3')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: