summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cb5540aa992
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=AUCell
+_pkgver=1.18.1
+pkgname=r-${_pkgname,,}
+pkgver=1.18.1
+pkgrel=1
+pkgdesc="AUCell: Analysis of 'gene set' activity in single-cell RNA-seq data (e.g. identify cells with specific gene signatures)"
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biocgenerics
+ r-data.table
+ r-gseabase
+ r-mixtools
+ r-r.utils
+ r-s4vectors
+ r-shiny
+ r-summarizedexperiment
+ r-delayedmatrixstats
+)
+optdepends=(
+ r-biobase
+ r-biocstyle
+ r-domc
+ r-doparallel
+ r-dorng
+ r-dosnow
+ r-dt
+ r-dynamictreecut
+ r-foreach
+ r-geoquery
+ r-knitr
+ r-nmf
+ r-plotly
+ r-plyr
+ r-r2html
+ r-rbokeh
+ r-reshape2
+ r-rmarkdown
+ r-rtsne
+ r-testthat
+ r-zoo
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('f969bb6262af856e71b846e650f41a26e87838464670d2d50b1450ca7c3b999f')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: