summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9203f8c882b2..061a4eaf71d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,28 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Alex Branham <branham@utexas.edu>
_cranname=bit
-_cranver=4.0.4
+_cranver=4.0.5
pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
+pkgver=${_cranver//-/.}
pkgrel=1
pkgdesc="Classes and Methods for Fast Memory-Efficient Boolean Selections"
arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2 GPL3)
-depends=('r>=2.9.2')
-optdepends=(r-testthat r-roxygen2 r-knitr r-rmarkdown r-microbenchmark r-bit64 r-ff)
+license=(GPL)
+depends=(r)
+optdepends=(
+ r-bit64
+ r-ff
+ r-knitr
+ r-microbenchmark
+ r-rmarkdown
+ r-roxygen2
+ r-testthat
+)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('e404841fbe4ebefe4ecd4392effe673a8c9fa05f97952c4ce6e2f6159bd2f168')
+sha256sums=('f0f2536a8874b6a30b80baefbc68cb21f0ffbf51f3877bda8038c3f9f354bfbc')
build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"