summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb5927b6b8d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=bnem
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='Training of logical models from indirect measurements of perturbation experiments'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-affy
+ r-binom
+ r-biobase
+ r-cellnoptr
+ r-epinem
+ r-flexclust
+ r-graph
+ r-limma
+ r-matrixstats
+ r-mnem
+ r-rcolorbrewer
+ r-rgraphviz
+ r-rmarkdown
+ r-snowfall
+ r-sva
+ r-vsn
+)
+optdepends=(
+ r-biocgenerics
+ r-knitr
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('22a4bfa37f0eb91f43aadfe46d6b4a7760b6a11fef9df074d249e0047c9f03e2')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: