summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7984c796f7f..29d193242db5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,31 @@
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Sauliusl <luksaulius at gmail>
+# Contributor: fordprefect <fordprefect@dukun.de>
_pkgname=caTools
_pkgver=1.18.2
pkgname=r-${_pkgname,,}
-pkgver=1.18.2
-pkgrel=7
-pkgdesc='Tools: Moving Window Statistics, GIF, Base64, ROC AUC, etc'
-arch=('x86_64')
+pkgver=${_pkgver//-/.}
+pkgrel=9
+pkgdesc="Tools: Moving Window Statistics, GIF, Base64, ROC AUC, etc"
+arch=(x86_64)
url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+license=(GPL3)
depends=(
- r
r-bitops
)
-optdepends=(
- r-mass
- r-rpart
-)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('c95edd3f71a8fe1ad2cfd0ae274ad9ab')
sha256sums=('75d61115afec754b053ed1732cc034f2aeb27b13e6e1932aa0f26bf590cf0293')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: