summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 22 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5eaaa3ea06a1..7fcbe696edf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,31 @@
-# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
-# Contributor: Sauliusl <luksaulius at gmail>
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
-_cranname=caTools
-_cranver=1.18.2
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
-pkgdesc="Tools: Moving Window Statistics, GIF, Base64, ROC AUC, etc"
-arch=(i686 x86_64)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL3)
-depends=('r>=3.6.0' r-bitops)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+_pkgname=caTools
+_pkgver=1.18.2
+pkgname=r-${_pkgname,,}
+pkgver=1.18.2
+pkgrel=4
+pkgdesc='Tools: Moving Window Statistics, GIF, Base64, ROC AUC, etc'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-bitops
+)
+optdepends=(
+ r-mass
+ r-rpart
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
sha256sums=('75d61115afec754b053ed1732cc034f2aeb27b13e6e1932aa0f26bf590cf0293')
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
}
+# vim:set ts=2 sw=2 et: