summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ccdb147dd462
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+#Maintainer: sukanka <su975853527 AT gmail.com>
+_pkgname=conting
+_pkgver=1.7.9999
+pkgname=r-${_pkgname,,}
+pkgver=1.7.9999
+pkgrel=1
+pkgdesc="Bayesian Analysis of Contingency Tables"
+arch=('any')
+url="https://github.com/vandenman/${_pkgname}"
+license=('GPL2')
+depends=(r
+ r-mvtnorm
+ r-gtools
+ r-tseries
+ r-coda
+)
+makedepends=('git')
+optdepends=()
+source=("git+https://github.com/vandenman/${_pkgname}.git")
+sha256sums=('SKIP')
+
+
+build() {
+ mkdir -p ${srcdir}/usr/lib/R/library
+ R -e "install.packages('${srcdir}/${_pkgname}',\
+ type='source', repos=NULL,lib='${srcdir}/usr/lib/R/library', INSTALL_opts='--no-multiarch --no-docs --no-test-load')"
+}
+
+package() {
+
+ cp -a --no-preserve=ownership "${srcdir}/usr" "${pkgdir}"
+}