summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3892c9e38454
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Stephen R. Martin <stephensrmmartin at gmail dot com>
+_cranname=RInside
+_cranver=0.2.14
+pkgname=r-cran-rcpp
+pkgver=${_cranver}
+pkgrel=1
+pkgdesc="Seamless R and C++ Integration"
+url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
+arch=('i686' 'x86_64')
+license=('GPL2' 'GPL3')
+depends=('r' 'r-cran-rcpp')
+source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('fc72761e22b1f597433eb53d6eb122ff')
+
+package() {
+ mkdir -p ${pkgdir}/usr/lib/R/library
+ cd ${srcdir}
+ R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+}