summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19b8bd59fc16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# system requirements: GNU make
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=diffuStats
+_pkgver=1.16.0
+pkgname=r-${_pkgname,,}
+pkgver=1.16.0
+pkgrel=1
+pkgdesc='Diffusion scores on biological networks'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-checkmate
+ r-expm
+ r-igraph
+ r-plyr
+ r-precrec
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppparallel
+ make
+)
+optdepends=(
+ r-biocstyle
+ r-ggplot2
+ r-ggsci
+ r-igraphdata
+ r-knitr
+ r-reshape2
+ r-rmarkdown
+ r-testthat
+ r-utils
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('161d9e3f4448802803cc0c5deb4ff198fffc4383dac963a12a735c44fa39795e')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: