summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb5b752999f5..db872a7a36ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,26 @@
# Maintainer: Alex Branham <branham@utexas.edu>
-# Contributor: generated by script at https://github.com/zasdfgbnm/aurcran
_cranname=digest
_cranver=0.6.15
+_pkgtar=${_cranname}_${_cranver}.tar.gz
pkgname=r-digest
pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Create compact hash digests of R objects"
+arch=('any')
url="https://cran.r-project.org/web/packages/${_cranname}/index.html"
-arch=('x86_64')
license=('GPL')
-optdepends=('r-knitr'
- 'r-rmarkdown')
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+depends=('r' )
+
+optdepends=('r-knitr' 'r-rmarkdown')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
md5sums=('94fe9e133a7fb19a89e05daac7b5e9da')
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
package() {
- mkdir -p ${pkgdir}/usr/lib/R/library
- cd "${srcdir}"
- R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
}
+