summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 18 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8376d8aca297..cb5b752999f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,21 @@
-# Maintainer: generated by script at https://github.com/zasdfgbnm/aurcran
-
-_pkgname=digest
-_pkgnamelower=digest
-_repo='http://cran.stat.ucla.edu/'
-_cran="https://cran.r-project.org/web/packages/$_pkgname/index.html"
-pkgname=r-$_pkgnamelower
-pkgver=0.6.10
+# Maintainer: Alex Branham <branham@utexas.edu>
+# Contributor: generated by script at https://github.com/zasdfgbnm/aurcran
+_cranname=digest
+_cranver=0.6.15
+pkgname=r-digest
+pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc='create compact hash digests of r objects'
-arch=(any)
-url="http://dirk.eddelbuettel.com/code/digest.html"
-license=('GPL2')
-depends=('r>=2.4.1')
-makedepends=('curl' 'grep' 'python-html2text')
-
-pkgver() {
- curl "$_cran" 2>/dev/null|html2text|grep -oP '(?<=Version:).*'|tr '-' '.'|grep -o '[0-9\.]*'
-}
-
-build() {
- Rscript -e "install.packages(\"$_pkgname\", lib=\"$srcdir\", repos=\"$_repo\")"
-}
+pkgdesc="Create compact hash digests of R objects"
+url="https://cran.r-project.org/web/packages/${_cranname}/index.html"
+arch=('x86_64')
+license=('GPL')
+optdepends=('r-knitr'
+ 'r-rmarkdown')
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('94fe9e133a7fb19a89e05daac7b5e9da')
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_pkgname" "$pkgdir/usr/lib/R/library"
-} \ No newline at end of file
+ mkdir -p ${pkgdir}/usr/lib/R/library
+ cd "${srcdir}"
+ R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+}