summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9af5eb8309d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+_cranname=DT
+_cranver=0.6
+pkgname=r-dt
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="A Wrapper of the JavaScript Library 'DataTables'"
+arch=('any')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('GPL3')
+depends=('r' 'r-htmltools' 'r-htmlwidgets' 'r-magrittr' 'r-crosstalk' 'r-promises')
+optdepends=('r-knitr' 'r-rmarkdown' 'r-shiny' 'r-jsonlite')
+source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('8d8b423d0d0699a507c78580599edad9')
+
+build(){
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l $srcdir
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -dm0755 "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "$_cranname" "$pkgdir/usr/lib/R/library"
+}