summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d4152c63471
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=eisaR
+_pkgver=1.8.0
+pkgname=r-${_pkgname,,}
+pkgver=1.8.0
+pkgrel=1
+pkgdesc='Exon-Intron Split Analysis (EISA) in R'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biocgenerics
+ r-edger
+ r-genomicranges
+ r-iranges
+ r-limma
+ r-s4vectors
+ r-summarizedexperiment
+)
+optdepends=(
+ r-annotationdbi
+ r-biocstyle
+ r-biostrings
+ r-bsgenome
+ r-bsgenome.hsapiens.ucsc.hg38
+ r-ensembldb
+ r-genomicfeatures
+ r-knitr
+ r-quasr
+ r-rbowtie
+ r-rhisat2
+ r-rmarkdown
+ r-rtracklayer
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('1c68706cf9031ef81636ed7a8ac2c82e536db7f638f3c80199bdee6e58ae36b0')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: