summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbd075d01b24..80bb91b8aa30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
-_cranver=0.14
_cranname=evaluate
-_pkgtar=${_cranname}_${_cranver}.tar.gz
-pkgname=r-evaluate
+_cranver=0.14
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc='Parsing and Evaluation Tools that Provide More Details than the Default'
-arch=('any')
-url='https://cran.r-project.org/package=evaluate'
-license=('MIT')
-depends=('r' )
-optdepends=('r-testthat' 'r-ggplot2')
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-md5sums=('8bcf26d1cc5b3f8fc14056ddfebcd295')
+pkgdesc="Parsing and Evaluation Tools that Provide More Details than the Default"
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(MIT)
+depends=('r>=3.0.2')
+optdepends=(r-testthat r-ggplot2)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+sha256sums=('a8c88bdbe4e60046d95ddf7e181ee15a6f41cdf92127c9678f6f3d328a3c5e28')
-build(){
- R CMD INSTALL evaluate_"$_cranver".tar.gz -l "$srcdir"
+build() {
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
}
+
package() {
- install -dm0755 "$pkgdir"/usr/lib/R/library
- cp -a --no-preserve=ownership evaluate "$pkgdir"/usr/lib/R/library
-}
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}