summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 22 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c03858b715eb..5738b81e7d5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
-# Maintainer: Jooa <aur at (name) dot xyz>
-pkgname=r-geosphere
-pkgver=1.5
-pkgrel=1
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Jooa <aur at (name) dot xyz>
+
_cranname=geosphere
-_cranrel=7
-_pkgfile=${_cranname}_${pkgver}-${_cranrel}.tar.gz
-pkgdesc="Spherical trigonometry for geographic applications."
+_cranver=1.5-10
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Spherical Trigonometry"
+arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
-arch=('x86_64' 'i686')
-license=('GPL3')
-depends=('r>=3.0' 'r-sp')
-optdepends=('r-raster')
-provides=('r-geosphere')
-source=(https://cran.r-project.org/src/contrib/${_pkgfile})
-sha256sums=('9d9b555e2d59a5ae174ae654652121f169fbc3e9cf66c2491bfbe0684b6dd8a0')
+license=(GPL3)
+depends=('r>=3.0.0' r-sp)
+makedepends=(gcc)
+optdepends=(r-raster)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('6e29eb221218e3e80bba9e8d4e3ee5b6')
build() {
- R CMD INSTALL ${_pkgfile} -l ${srcdir}
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
package() {
- install -d ${pkgdir}/usr/lib/R/library
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}