summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5dfe11937c1..eaaebde5a821 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=ggfun
-_pkgver=0.1.3
+_pkgver=0.1.5
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Miscellaneous Functions for 'ggplot2'"
arch=(any)
-url="https://cran.r-project.org/package=${_pkgname}"
-license=(Artistic2.0)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('Artistic-2.0')
depends=(
r-cli
+ r-dplyr
r-ggplot2
r-rlang
)
@@ -24,12 +25,12 @@ optdepends=(
r-tidyr
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-md5sums=('e4f9b170524457f12082835281af2990')
-sha256sums=('89232ea73b7bcf3262ce4f66c7f6d05b00c5c79927c9c16d3ba8f816332669ca')
+md5sums=('1f0e6042e9d7b6138874caa30a8b8f58')
+b2sums=('5a06adcb8fd8cd25ec5919cbc01cd11a778fac2cc5ac098a35c019ab276d998e9f4ffd2e60da9ee13a545145a841a6f3ebb30ea384b162b856f255470e6157b7')
build() {
- mkdir -p build
- R CMD INSTALL "$_pkgname" -l build
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {