summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c0418f76229..712a83784820 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=GOSemSim
-_pkgver=2.28.0
+_pkgver=2.28.1
pkgname=r-${_pkgname,,}
-pkgver=2.28.0
-pkgrel=3
-pkgdesc='GO-terms Semantic Similarity Measures'
-arch=('x86_64')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('Artistic2.0')
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="GO-terms Semantic Similarity Measures"
+arch=(x86_64)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('Artistic-2.0')
depends=(
- r
r-annotationdbi
r-go.db
- r-rcpp
r-rlang
+ r-yulab.utils
+)
+makedepends=(
+ r-rcpp
)
optdepends=(
r-annotationhub
@@ -24,6 +26,7 @@ optdepends=(
r-knitr
r-org.hs.eg.db
r-prettydoc
+ r-readr
r-rmarkdown
r-rocr
r-testthat
@@ -31,14 +34,15 @@ optdepends=(
r-tidyselect
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('081dc5cdb6ea3cc8f19cff4c7c0f4cfdedb7711dece39372658983e0de975082')
+md5sums=('89d833af368b8fb6592d7acd623e0a45')
+b2sums=('585b7071c621cfcd0d52b460fd854fe919313d58c7f54f8267c5e3d88df400e28ba6b05762a81b5649562b4d5e14710b6be17fb27a8448f946bc7ba997eb6cdd')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: