summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6992a9641cd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# system requirements: GSL and OpenMP
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=iBMQ
+_pkgver=1.36.0
+pkgname=r-${_pkgname,,}
+pkgver=1.36.0
+pkgrel=1
+pkgdesc='integrated Bayesian Modeling of eQTL data'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-biobase
+ r-ggplot2
+ gsl
+ openmpi
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('2d878aa1484be12a9bfc673d67ee3c0fc54892b6448eb58d23a16e2e4e86251c')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: