summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 22 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0b748319a0c..610a4650983e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,30 @@
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
-pkgname=r-matrixstats
-_cran_name=matrixStats
-pkgver=0.55.0
+
+_cranname=matrixStats
+_cranver=0.55.0
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Functions that Apply to Rows and Columns of Matrices (and to Vectors)"
-arch=('x86_64')
-url="https://CRAN.R-project.org/package=${_cran_name}"
-license=('GPL3')
-depends=('r')
-source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
+arch=(i686 x86_64)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(Artistic-2.0)
+depends=('r>=2.12.0')
+makedepends=(gcc)
+optdepends=(r-base64enc r-ggplot2 r-knitr r-microbenchmark r-r.devices r-r.rsp)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
md5sums=('860aa7af56ddb598268cbca7921e2d4c')
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
+
package() {
- mkdir -p $pkgdir/usr/lib/R/library
- cd $srcdir
+ cd "${srcdir}"
- R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}