summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5e09e024870
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=meshr
+_pkgver=2.2.0
+pkgname=r-${_pkgname,,}
+pkgver=2.2.0
+pkgrel=1
+pkgdesc='Tools for conducting enrichment analysis of MeSH'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-biocgenerics
+ r-biocstyle
+ r-category
+ r-fdrtool
+ r-knitr
+ r-markdown
+ r-meshdbi
+ r-rmarkdown
+ r-rsqlite
+ r-s4vectors
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('b43933d6d71d7aed07bacdc1b4926fdbf67d5cb7c03704dd8ddd78d5ca975dbd')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: