summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 27 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 087c71b08f98..44263a1b7bcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,36 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
-# Contributor: Alex Branham <branham@utexas.edu>
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
-_cranname=openxlsx
-_cranver=4.2.5
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
-pkgdesc="Read, Write and Edit xlsx Files"
-arch=(i686 x86_64)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(MIT)
-depends=('r>=3.3.0' r-rcpp r-stringi r-zip)
-optdepends=(r-knitr r-rmarkdown r-roxygen2 r-testthat)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+_pkgname=openxlsx
+_pkgver=4.2.5
+pkgname=r-${_pkgname,,}
+pkgver=4.2.5
+pkgrel=4
+pkgdesc='Read, Write and Edit xlsx Files'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-rcpp
+ r-stringi
+ r-zip
+)
+optdepends=(
+ r-knitr
+ r-rmarkdown
+ r-roxygen2
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
sha256sums=('65d06d2819b656ac30fc78437ee712a83fb5a7ab750f56268e5c9e578c582519')
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
+# vim:set ts=2 sw=2 et: