summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 3 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca39231ef82d..9df3e41e85ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@ _cranname=processx
_cranver=3.5.2
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
-pkgrel=2
+pkgrel=3
pkgdesc="Execute and Control System Processes"
arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
license=(MIT)
-depends=(r r-ps r-r6)
+depends=(r-ps r-r6)
checkdepends=(r-curl r-testthat)
optdepends=(
r-callr
@@ -23,18 +23,10 @@ optdepends=(
r-withr
)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz"
- "error-test.patch::https://github.com/r-lib/processx/pull/321.patch"
"R-MIT-TEMPLATE::https://cran.r-project.org/web/licenses/MIT")
sha256sums=('ed6f2d1047461c6061e6ed58fb6de65a289b56009867892abad76c6bba46fc2b'
- '9f55e81165f3bf09be189d683017fce3b0cc5f39687b5b23c88fd401b7a82758'
'e76e4aad5d3d9d606db6f8c460311b6424ebadfce13f5322e9bae9d49cc6090b')
-prepare() {
- cd "${_cranname}"
- # Fix two tests that don't work with a non-English locale
- patch -Np1 -i "${srcdir}/error-test.patch"
-}
-
build() {
mkdir -p build
R CMD INSTALL "${_cranname}" -l "${srcdir}/build"
@@ -42,7 +34,7 @@ build() {
check() {
cd "${_cranname}/tests"
- R_LIBS="${srcdir}/build" NOT_CRAN=true R --vanilla -q -f testthat.R
+ R_LIBS="${srcdir}/build" NOT_CRAN=true LC_MESSAGES=C Rscript --vanilla testthat.R
}
package() {