summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7f31390c0bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# system requirements: C++11
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=proxyC
+_pkgver=0.2.4
+pkgname=r-${_pkgname,,}
+pkgver=0.2.4
+pkgrel=4
+pkgdesc='Computes Proximity in Large Sparse Matrices'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppparallel
+)
+optdepends=(
+ r-entropy
+ r-proxy
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('a63975fc77df91e0c4db6d3bceac26eeca015f767f3ecd4f9592859eb9ae91d5')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: