summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53120c8d64ef..336f45ac758c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
+# Maintainer: peippo <christoph+aur@christophfink.com>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
_bcname=Rhtslib
-_bcver=1.26.0
+_bcver=1.28.0
pkgname=r-${_bcname,,}
pkgver=${_bcver//[:-]/.}
pkgrel=1
@@ -14,7 +15,7 @@ depends=(r r-zlibbioc bzip2 xz curl)
makedepends=(make)
optdepends=(r-knitr r-rmarkdown r-biocstyle)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_bcname}_${_bcver}.tar.gz")
-sha256sums=('24bba61616e7d4fc57fda86172486b92ffcae31d1a7183d7b8ee29e324ff955f')
+sha256sums=('4e48c8643e5d3429238ee76faa4c68ed8a7028e7f594c109ee75f5e994d17c1e')
options=(staticlibs)
build() {
@@ -23,6 +24,9 @@ build() {
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
-
cp -a --no-preserve=ownership "${_bcname}" "${pkgdir}/usr/lib/R/library"
+
+ if [[ -f "${_cranname}/LICENSE" ]]; then
+ install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ fi
}