summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD70
1 files changed, 70 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60a78fb10820
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=rrvgo
+_pkgver=1.8.0
+pkgname=r-${_pkgname,,}
+pkgver=1.8.0
+pkgrel=1
+pkgdesc='Reduce + Visualize GO'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-annotationdbi
+ r-ggplot2
+ r-ggrepel
+ r-go.db
+ r-gosemsim
+ r-pheatmap
+ r-shiny
+ r-tm
+ r-treemap
+ r-wordcloud
+)
+optdepends=(
+ r-biocstyle
+ r-clusterprofiler
+ r-dose
+ r-dt
+ r-heatmaply
+ r-knitr
+ r-magrittr
+ r-org.ag.eg.db
+ r-org.at.tair.db
+ r-org.bt.eg.db
+ r-org.ce.eg.db
+ r-org.cf.eg.db
+ r-org.dm.eg.db
+ r-org.dr.eg.db
+ r-org.eck12.eg.db
+ r-org.ecsakai.eg.db
+ r-org.gg.eg.db
+ r-org.hs.eg.db
+ r-org.mm.eg.db
+ r-org.mmu.eg.db
+ r-org.pf.plasmo.db
+ r-org.pt.eg.db
+ r-org.rn.eg.db
+ r-org.sc.sgd.db
+ r-org.ss.eg.db
+ r-org.xl.eg.db
+ r-plotly
+ r-rmarkdown
+ r-shinydashboard
+ r-slam
+ r-testthat
+ r-utils
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('7d97ac93d0f076ec5144b2b474e7f2eb7bb6462f31c4255b21f0576851c020e5')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: