summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 27 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6c20500c4b7..b572d4b7dacd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,36 @@
-# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
-_cranname=sessioninfo
-_cranver=1.2.2
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
-pkgdesc="R Session Information"
-arch=(any)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2)
-depends=('r>=2.10' 'r-cli>=3.1.0')
-optdepends=(r-callr r-covr r-mockery r-reticulate r-rmarkdown r-testthat r-withr)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+_pkgname=sessioninfo
+_pkgver=1.2.2
+pkgname=r-${_pkgname,,}
+pkgver=1.2.2
+pkgrel=4
+pkgdesc='R Session Information'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-cli
+)
+optdepends=(
+ r-callr
+ r-covr
+ r-mockery
+ r-reticulate
+ r-rmarkdown
+ r-testthat
+ r-withr
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
sha256sums=('f56283857c53ac8691e3747ed48fe03e893d8ff348235bff7364658bcfb0c7cb')
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
}
+# vim:set ts=2 sw=2 et: