summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1730578adfda..b57050521e7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Alex Branham <branham@utexas.edu>
_pkgname=SQUAREM
_pkgver=2021.1
pkgname=r-${_pkgname,,}
-pkgver=2021.1
-pkgrel=10
-pkgdesc='Squared Extrapolation Methods for Accelerating EM-Like Monotone Algorithms'
-arch=('any')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=12
+pkgdesc="Squared Extrapolation Methods for Accelerating EM-Like Monotone Algorithms"
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
+license=(GPL)
depends=(
r
)
@@ -18,14 +18,15 @@ optdepends=(
r-setrng
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('66e5e18ca29903e4950750bbd810f0f9df85811ee4195ce0a86d939ba8183a58')
+md5sums=('529ce81903111315c68131f0452a939f')
+b2sums=('2be8b6f40e8c1c3b0709966a9a4d88e742a7ebefbb571fb2a9eadf1ee067acc992ecf6fa08fa0322aa74182e90d5a9a58403ce94639ae80ad24a2163c05d05d9')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: