summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd41f62e9cd5..11bc89497961 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Contributor: sukanka <su975853527@gmail.com>
_pkgname=vdiffr
-_pkgver=1.0.5
+_pkgver=1.0.6
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
-pkgrel=3
+pkgrel=1
pkgdesc="Visual Regression Testing and Graphical Diffing"
arch=(x86_64)
url="https://cran.r-project.org/package=${_pkgname}"
@@ -33,17 +33,17 @@ optdepends=(
r-withr
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
- "skip_tests.patch::https://github.com/r-lib/vdiffr/commit/630a29d013361fd63fea242f531e2db6aef37919.patch")
-md5sums=('7f4d2da1db46098dce493e0df022db9c'
+ "$pkgname-skip_tests.patch::https://github.com/r-lib/vdiffr/commit/630a29d013361fd63fea242f531e2db6aef37919.patch")
+md5sums=('e7fe2f95c2c2560eb6cbcb58a3aedc45'
'2f12d37581d0e3af037a7066bdb9ee3b')
-sha256sums=('0cbf7b72fcb7346a83a488c63b6b786fc2a4c5465093665ad2dee05396c4d0f0'
+sha256sums=('620194676791fbbb303ea998d12544017d97c4ee975fed1e416ae99de74d23d6'
'66c843887b82cc78edd9300ef38140b19924a29c77e736897bef7520a5bb0d2f')
prepare() {
cd "$_pkgname"
# revert a commit that disables all tests
- patch -Rp1 -i ../skip_tests.patch
+ patch -Rp1 -i "../$pkgname-skip_tests.patch"
# fix test snapshot
sed -i 's/square/butt/' tests/testthat/_snaps/expect-doppelganger/myplot.svg