summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec2e69e5af3c..13407cf379c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
+# Maintainer: peippo <christoph+aur@christophfink.com>
+# Maintainer: Grey Christoforo <first name at last name dot net>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
_cranname=waldo
-_cranver=0.3.1
+_cranver=0.4.0
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
@@ -9,10 +11,10 @@ pkgdesc="Find Differences Between R Objects"
arch=(any)
url="https://cran.r-project.org/package=${_cranname}"
license=(MIT)
-depends=(r r-cli 'r-diffobj>=0.3.4' r-fansi r-glue r-rematch2 'r-rlang>=0.4.10' r-tibble)
-optdepends=(r-testthat r-covr r-r6 r-withr r-xml2)
+depends=(r r-cli 'r-diffobj>=0.3.4' r-fansi r-glue r-rematch2 'r-rlang>=1.0.0' r-tibble)
+optdepends=(r-covr r-r6 r-testthat r-withr r-xml2)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('ec2c8c1afbc413f8db8b6b0c6970194a875f616ad18e1e72a004bc4497ec019b')
+sha256sums=('57ee89eec9bcbba58cf8fa29c8e097f038768c30833eaf812682826333127eaa')
build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
@@ -22,4 +24,8 @@ package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+
+ if [[ -f "${_cranname}/LICENSE" ]]; then
+ install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ fi
}