summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 28 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1cae6545471..23ace45c7380 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,36 @@
-# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
-# Contributor: Alex Branham <branham@utexas.edu>
-_cranname=xts
-_cranver=0.12.1
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
-pkgdesc="Provide for uniform handling of R's different time-based data classes by extending zoo, maximizing native format information preservation and allowing for user level customization and extension, while simplifying cross-class interoperability."
-arch=(any)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL)
-depends=('r-zoo>=1.7.12')
-optdepends=(r-timeseries r-timedate r-tseries r-chron r-fts r-tis r-runit)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=xts
+_pkgver=0.12.1
+pkgname=r-${_pkgname,,}
+pkgver=0.12.1
+pkgrel=4
+pkgdesc='eXtensible Time Series'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-zoo
+)
+optdepends=(
+ r-chron
+ r-fts
+ r-runit
+ r-timedate
+ r-timeseries
+ r-tis
+ r-tseries
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
sha256sums=('d680584af946fc30be0b2046e838cff7b3a65e00df1eadba325ca5e96f3dca2c')
build() {
- cd "${srcdir}"
-
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
}
package() {
- cd "${srcdir}"
-
install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
}
-
+# vim:set ts=2 sw=2 et: