summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a15e488bdd16..90ecc6298dff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,12 @@
+# Maintainer: Juan Simón <play4pro at protonmail dot com>
+# Contributor: alium
+# Contributor: angelsl
_pkgbase=r8168
pkgname=${_pkgbase}-dkms
pkgver=8.047.05
-pkgrel=1
+pkgrel=2
pkgdesc="A kernel module for Realtek 8168 network cards"
-url="http://www.realtek.com.tw"
+url="https://github.com/mtorromeo/r8168"
license=("GPL")
arch=('i686' 'x86_64')
depends=('glibc' 'dkms')
@@ -12,13 +15,14 @@ optdepends=('linux-headers: Needed for build the module for Arch kernel'
'linux-lts-headers: Needed for build the module for LTS Arch kernel'
'linux-zen-headers: Needed for build the module for ZEN Arch kernel')
source=(https://github.com/mtorromeo/r8168/archive/$pkgver/$pkgname-$pkgver.tar.gz
- dkms.conf)
+ dkms.conf
+ kernel-5.4.patch)
install=r8168-dkms.install
-#prepare() {
-# cd "r8168-$pkgver"
-# patch -p1 -i "$srcdir/linux-4.15-2.patch"
-#}
+prepare() {
+ cd "r8168-$pkgver"
+ patch -Np1 -i "${srcdir}/kernel-5.4.patch"
+}
package() {
@@ -33,4 +37,5 @@ package() {
cp -dr --no-preserve='ownership' src "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/src"
}
sha256sums=('1344bf3d8a1d01a1be8805b48940be1b946b5e694ca75bd14ed1c76fd4c3d67b'
- '260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763')
+ 'e33abcbc8fbe3129459ebc60be3b2f8ed55ddc53755f4956d6feb16c61c43250'
+ 'be79c151c6323bb4d340e31e44fae25a36a93d317812fe5d75c54649ed2508b0')