summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ec58388db48..94df451bf12b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
_pkgbase=r8168
pkgname=${_pkgbase}-dkms
pkgver=8.045.08
-pkgrel=1
+pkgrel=2
pkgdesc="A kernel module for Realtek 8168 network cards"
url="http://www.realtek.com.tw"
license=("GPL")
@@ -13,14 +13,14 @@ optdepends=('linux-headers: Needed for build the module for Arch kernel'
'linux-zen-headers: Needed for build the module for ZEN Arch kernel')
#source=(https://github.com/mtorromeo/r8168/archive/$pkgver/r8168-$pkgver.tar.gz
source=(http://12244.wpc.azureedge.net/8012244/drivers/rtdrivers/cn/nic/0010-r8168-8.045.08.tar.bz2
- 'dkms.conf')
-# linux-4.11.patch)
+ dkms.conf
+ linux-4.15.patch)
install=r8168-dkms.install
-#prepare() {
-# cd "r8168-$pkgver"
-# patch -p1 -i "$srcdir/linux-4.11.patch"
-#}
+prepare() {
+ cd "r8168-$pkgver"
+ patch -p1 -i "$srcdir/linux-4.15.patch"
+}
package() {
@@ -35,4 +35,5 @@ package() {
cp -dr --no-preserve='ownership' src "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/src"
}
sha256sums=('29a17aa12b80786cf016799bbe01da8fdd8ee0a4e90b18e740935d81046ec74d'
- '260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763')
+ '260d8142e944f3144cbc704534e662d427318d8b32dc7a2852a855be72e8d763'
+ '0a3d99dae38a55fa8456a9883db8a0fd65f7042391daff8b978eced4749e1dc7')