summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4edb83d13e1b..b7c1f907d6ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,26 @@
# Maintainer: Zeph <zeph33@gmail.com>
pkgname=rabbitvcs
-pkgver=0.17.1
+pkgver=0.17.2
pkgrel=1
+_gitcommit='e7d5a82836855675b11cc860bc9cc3ce56864ffd'
pkgdesc="A project with the goal of developing a collection of utilities to allow for better client integration with some of the popular version control systems (core)"
arch=('any')
#url="http://rabbitvcs.org/"
url="https://github.com/rabbitvcs/rabbitvcs"
install=${pkgname}.install
changelog=${pkgname}.changelog
-depends=('git' 'pygtk' 'python2-pysvn' 'python2-dulwich' 'python2-gobject2' 'python2-configobj' 'python2-simplejson' 'python2-gtkspellcheck' 'tk')
+depends=('git' 'gtk3' 'python-pysvn' 'python-dulwich' 'python-gobject' 'python-configobj' 'python-simplejson' 'python-gtkspellcheck' 'tk')
optdepends=('meld: graphical diff viewer')
-makedepends=('python2-setuptools')
+makedepends=('python-setuptools')
license=('GPL')
-_gitcommit=""
if [ "${_gitcommit}" != "" ]; then
source=("rabbitvcs-$pkgver-$pkgrel.tar.gz::$url/archive/$_gitcommit.tar.gz")
else
source=("rabbitvcs-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
fi
-md5sums=('95b7c30945f10333588a39b5f6766136')
-#md5sums=('SKIP')
+sha256sums=('658f410d29baf615f668ff0d787e5f3769c887d3077a307b6da9d2169291fa5f')
+#sha256sums=('SKIP')
build() {
@@ -29,14 +29,15 @@ build() {
mv "$srcdir/rabbitvcs-$_gitcommit" "$srcdir/rabbitvcs-$pkgver"
fi
cd "$srcdir/$pkgname-$pkgver"
- sed -i "s#env python#env python2#" setup.py
- sed -i "s#!= 'Darwin'#== 'toto'#" setup.py
- sed -i "s#import hashlib#import hashlib, urllib#" ./rabbitvcs/util/helper.py
- find . -name "*.py" | xargs grep -l sys.executable | xargs sed -i 's|sys\.executable|"/usr/bin/python2"|g'
- python2 setup.py build
+ sed -i "s#0.17.1#${pkgver}#" ./rabbitvcs/__init__.py
+ sed -i "s#0.17.1#${pkgver}#" setup.py
+ # sed -i "s#!= 'Darwin'#== 'toto'#" setup.py
+ # sed -i "s#import hashlib#import hashlib, urllib#" ./rabbitvcs/util/helper.py
+ # find . -name "*.py" | xargs grep -l sys.executable | xargs sed -i 's|sys\.executable|"/usr/bin/python2"|g'
+ python setup.py build
}
package(){
cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
}