summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3066ff2e52ba..7a859b5d1a49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Vincent (maximevince) <maxime [dot] vince [at] gmail [dot] com>
pkgname=radare2-cutter-ghidra
-pkgver=1.9.0.r23.gb11ba240
+pkgver=1.9.0.r49.g524b27fa
pkgrel=1
pkgdesc='A Qt and C++ GUI for radare2 reverse engineering framework with Python and Ghidra support'
url='https://github.com/radareorg/cutter'
@@ -22,9 +22,12 @@ pkgver() {
}
prepare() {
+ sed -e 's|PKGCONFIG += python3|PKGCONFIG += python3-embed|' -i $pkgname/src/Cutter.pro # Fix linking to python 3.8
+
cd ${pkgname}
git submodule update --init --recursive
+
mkdir -p build
cd build
git clone --depth 1 --recurse-submodules https://github.com/radareorg/r2ghidra-dec.git