summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 18 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f49f9cdb02a..b7332650adea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,38 @@
# Maintainer: FennecTECH <fennectech@gmail.com>
-# Based uppon the script for radegast written by Mike Swanson <mikeonthecomputer@gmail.com>
-pkgname=radegast-git
-pkgver=master
-pkgrel=43
+# Thank to
+# Latif Khalifa for the radegast project
+# Cinder Roxley For mantaining the project
+# Chungy Nexen For the origional radegast aur package
+# Robot Silvershade For teaching me most of the things I know.
+# Zach Ward & Beth Randall They have been there from my best day to my worst
+# And everyone else who I did'nt mention by name You are all important to me
+pkgname=radegast-ng
+pkgver=2.32.137
+pkgrel=1.4
pkgdesc="Lightweight client for connecting to Second Life and OpenSim worlds"
arch=('i686' 'x86_64')
url="http://radegast.org"
license=('BSD')
depends=('mono')
-conflicts=('radegast')
+conflicts=('radegast' 'radegast-git')
makedepends=('dos2unix' 'recode')
-source=(radegast.desktop radegast)
-sha256sums=('8f599f04f263361cd45f7af53cfae633881bfa92ba3f806a0ca675d1ee131567'
+source=(https://bitbucket.org/cinderblocks/radegast/downloads/Radegast-${pkgver}.tbz
+ radegast.desktop radegast)
+sha256sums=('65ebfc75101c99fd1c8ebe13e5b88284c400353730202996341e02ec898dd666'
+ '8f599f04f263361cd45f7af53cfae633881bfa92ba3f806a0ca675d1ee131567'
'73cdc80cc4abeb6ba368b09285ff5120ffeb6052a0a5e5ac0febf08c38bb0e96')
-
-build() {
- git clone --recursive https://github.com/radegastdev/radegast.git radegast-git-master-src
- cd "${srcdir}"/$pkgname-$pkgver-src
- find .. -name \*.sh -exec dos2unix '{}' \;
- bash runprebuild.sh
- xbuild Radegast.sln
-}
-
package() {
- cd "${srcdir}"/$pkgname-$pkgver-src/bin
+ cd ../src/bin
find . -type d -print0 | xargs -0 chmod 755
find . -type f -print0 | xargs -0 chmod 644
install -dm755 "${pkgdir}"/usr/share/Radegast
cp -a -- * "${pkgdir}"/usr/share/Radegast
- install -Dm644 ../Radegast/radegast.png "${pkgdir}"/usr/share/icons/radegast.png
+ install -Dm644 ../bin/radegast.png "${pkgdir}"/usr/share/icons/radegast.png
install -Dm644 "${srcdir}"/radegast.desktop "${pkgdir}"/usr/share/applications/radegast.desktop
install -Dm755 "${srcdir}"/radegast "${pkgdir}"/usr/bin/radegast
install -dm755 "${pkgdir}"/usr/share/licenses/radegast
- recode windows-1252..utf8 < ../LICENSE.txt > "${pkgdir}"/usr/share/licenses/radegast/COPYING
+ recode windows-1252..utf8 < ../bin/license.txt > "${pkgdir}"/usr/share/licenses/radegast/COPYING
}
# vim:set ts=2 sw=2 et: