summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac262cf203c3..e8135f3524ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,26 @@
_name=radio-active
pkgname=radioactive
pkgver=2.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Play and record any radio stations around the globe right from your terminal."
arch=('any')
url="https://github.com/deep5050/radio-active"
license=('MIT')
-depends=('ffmpeg' 'python-colorlog' 'python-pick' 'python-psutil' 'python-pyradios>=1.0.2' 'python-requests-cache' 'python-rich' 'python-zenlog')
+depends=('ffmpeg' 'python-colorlog' 'python-pick' 'python-psutil' 'python-pyradios=1.0.2' 'python-requests-cache' 'python-rich' 'python-zenlog')
makedepends=('python-setuptools')
-conflicts=('radio-active')
+cpnflicts=("radio-active")
source=("$pkgname-$pkgver.tar.gz::https://github.com/deep5050/radio-active/archive/refs/tags/v$pkgver.tar.gz")
md5sums=('7a9a7710f094e9019d8d6f960ffa5e38')
build() {
cd "$_name-$pkgver"
- python setup.py build
+ #python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --skip-build --optimize=1
+ #python setup.py install --root="$pkgdir" --skip-build --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}