summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25489de1d55c..1b6cc5775f80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: twa022 <twa022 at gmail dot com>
pkgname=radiotray-ng
-pkgver=0.2.5
+pkgver=0.2.6
pkgrel=1
pkgdesc="An Internet radio player for Linux"
arch=('i686' 'x86_64')
@@ -10,14 +10,17 @@ license=('GPL')
depends=('boost-libs' 'curl' 'gst-plugins-good' 'jsoncpp' 'libappindicator-gtk3'
'libbsd' 'libnotify' 'libxdg-basedir' 'glibmm' 'wxgtk3')
makedepends=('cmake' 'boost' 'lsb-release')
-optdepends=('python2-lxml: Convert radiotray bookmarks to radiotray-ng format')
+optdepends=('python-lxml: Convert radiotray bookmarks to radiotray-ng format')
options=('!libtool')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v${pkgver}.tar.gz")
-sha256sums=('9b34f13f4290c98be9be555873d05507bbe7bcaa4ad0924655a4f38c8d55fe64')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v${pkgver}.tar.gz"
+ 'rt2rtng_python3.patch')
+sha256sums=('05e1b9ac7342b276fff6395a38719264f9bc47b28aadd4938c5bbe3303c67553'
+ '1965811963d5e02f08231f1c53a8a6db0bf146d8e745e8b7c76f3521f82142a3')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- sed -i 's:-Werror::' CMakeLists.txt
+# sed -i 's:-Werror::' CMakeLists.txt
+ patch -Np1 -i ../rt2rtng_python3.patch
}
build() {