summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD100
1 files changed, 71 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 972384d9598f..1619aa3d70ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
-# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
-# Maintainer: Teteros <teteros at teknik dot io>
+# Maintainer: yustin <#archlinux-proaudio@libera.chat>
+# Contributor: Teteros <teteros at teknik dot io>
+# Contributor: Karol "Kenji Takahashi" Woźniak <kenji.sx>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=radium
-pkgver=5.9.95
+pkgver=7.3.84
pkgrel=1
pkgdesc='A graphical music editor. A next generation tracker.'
-arch=(i686 x86_64)
+arch=(x86_64)
url=https://users.notam02.no/~kjetism/radium
license=(GPL2)
+groups=(pro-audio)
depends=(
desktop-file-utils
fftw
@@ -16,72 +18,112 @@ depends=(
gsfonts
hicolor-icon-theme
jack
+ liblo
liblrdf
libmpc
libsndfile
python2
+ qt5-svg
qt5-webkit
qt5-x11extras
speex
ttf-bitstream-vera
+ ttf-croscore
ttf-lato
-)
+ libatomic_ops
+ libsamplerate
+ tk
+ guile
+ libxkbfile
+ openssl
+ ncurses
+ gmp
+ xcb-util-keysyms
+ mpfr
+ libmpc
+ libogg
+ libvorbis
+ openssl
+ alsa-lib
+ glib2
+ binutils
+ xorg-util-macros
+ qt5-base
+ libmicrohttpd
+ ladspa
+ )
makedepends=(
boost
- clang
cmake
- ladspa
libxcursor
libxinerama
libxkbfile
libxrandr
- llvm
+ llvm15
+ clang15
qt5-tools
- steinberg-vst36
+ vst2sdk
)
optdepends=(
- 'calf-ladspa: Default chorus plugin'
- 'ladspa-plugins: Package group for default radium plugins incl in binary releases'
+ 'new-session-manager: for session management'
+ 'calf-ladspa: default chorus plugin used in new file templates'
+ 'ladspa-plugins: package group for plugins normally included in binary releases'
+ 'vst-plugins: more plugins'
+)
+options=( !strip )
+source=("$pkgname-$pkgver.tar.gz::https://github.com/kmatheussen/radium/archive/$pkgver.tar.gz"
+ radium.install
+ build_linux_common.patch
)
-options=(!strip)
-source=(https://github.com/kmatheussen/radium/archive/$pkgver.tar.gz
- use-system-libxcb.patch
- use-system-vstsdk.patch)
-sha256sums=('2bfa5c7cef62cb99261a244d1812c4bcf4bdcb537e1c35f75d354c8e6ee04eaf'
- '6c29e825e06d1c3aec4afd915718b8c46da705d1411a94f7c0f777b888a9b50d'
- '045e4b4c444d1a37dffdcecb87e5245188fadf68444f9a4b14207a5b98671344')
+sha256sums=('99d42a56491812cbc04fa14f463588740eb2bed8c2f58eadd6e8f45b239fd3f6'
+ 'f627730ff7a819e8cc5ac5c2b5f1fb2f2237327db6ea5442c55a23c1ce82ef14'
+ '0decfc3adcba836004ac34d970a83d4d0b69743334a586f42be53b3de7bdd5a4'
+ )
+install=radium.install
prepare() {
cd radium-$pkgver
- # Use system libxcb 1.13 rather than try to compile it
- patch -p1 < "$srcdir/use-system-libxcb.patch"
-
- # Set VST SDK location to steinberg-vst36 rather than look for it in user's home folder
- patch -p1 < "$srcdir/use-system-vstsdk.patch"
+ # use llvm15 to compile
+ export PATH=$(pwd):$PATH
+ ln -sf /usr/lib/llvm15/bin/clang clang
+ ln -sf /usr/bin/llvm-config-15 llvm-config
- # Edit new file template and demo songs to be compatible with chorus plugin from calf-ladspa
+ # fix for binutils 2.40
+ patch -p0 < "$srcdir/build_linux_common.patch"
+
+ # This tweak edits new file template and demo songs to be compatible with chorus plugin from calf-ladspa package
+ # New Demosong also needs fixes for LADSPA-Plugins
+ # !! NOTE TO LMMS USERS !!
+ # !! Comment next line out if you have LMMS installed as it already comes with their own version of Calf plugins !!
for file in bin/sounds/*.rad; do sed -i -e 's/Calf MultiChorus LADSPA/Calf Multi Chorus LADSPA/g' "$file"; done
+ for file in bin/sounds/*.RAD; do sed -i -e 's/Calf MultiChorus LADSPA/Calf Multi Chorus LADSPA/g' "$file"; done
+ sed -ie "s/C\* Eq - 10-band equalizer/C\* Eq10 - 10-band equaliser/g" bin/sounds/ROMANCE2.RAD
+ # See comment on calf-ladspa AUR page then on how to let Radium load Calf from LMMS package
}
build() {
cd radium-$pkgver
+ export PATH=$(pwd):$PATH
+ export INCLUDE_FAUSTDEV_BUT_NOT_LLVM=1
- RADIUM_USE_CLANG=1 RADIUM_QT_VERSION=5 make packages
- RADIUM_USE_CLANG=1 RADIUM_QT_VERSION=5 BUILDTYPE=RELEASE ./build_linux.sh
+ RADIUM_QT_VERSION=5 RADIUM_VST2SDK_PATH=/usr/include/vst36 RADIUM_BUILD_LIBXCB=0 make packages
+ RADIUM_QT_VERSION=5 RADIUM_VST2SDK_PATH=/usr/include/vst36 BUILDTYPE=RELEASE ./build_linux.sh
}
package() {
cd radium-$pkgver
# Install radium and its packages to /opt
- ./install.sh "$pkgdir/opt"
+ RADIUM_INSTALL_LIBXCB=0 ./install.sh "$pkgdir/opt"
+ # radium.install will link ladspa-path here so remove it
+ rm -rf $pkgdir/opt/radium/ladspa
# Create startup script according to bin/packages/README
mkdir -p "$pkgdir/usr/bin"
echo '#!/usr/bin/env bash' > "$pkgdir/usr/bin/radium"
echo QT_QPA_PLATFORM_PLUGIN_PATH="$($(RADIUM_QT_VERSION=5 ./find_moc_and_uic_paths.sh qmake) -query QT_INSTALL_PLUGINS)" \
- /opt/radium/radium >> "$pkgdir/usr/bin/radium"
+ /opt/radium/radium '"$@"' >> "$pkgdir/usr/bin/radium"
chmod +x "$pkgdir/usr/bin/radium"
# Icons, .desktop and mimetype files