summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 27 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70099f660542..85ad43d77cd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=radium
-pkgver=4.2.8
+pkgver=4.2.9
pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
@@ -32,6 +32,7 @@ makedepends=(
'qt5-tools'
'libxrandr'
'steinberg-vst36'
+ 'libpthread-stubs'
)
options=(!strip)
source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
@@ -39,7 +40,7 @@ source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
"dont-empty-qt-library-paths.patch"
"use-gcc5-for-pluginhost.patch"
"use-system-vstsdk.patch")
-md5sums=('6549f8ef8ed3419afc1de9f700cea178'
+md5sums=('61e8aa38ed8f464a7d6b85bc490674f8'
'9c72bd466ead73e36b0c2d4297d76870'
'77c202bc0a36562eb7b805ad6b7a85b3'
'9c19006defeef7e317ec23ed8eae1b72'
@@ -48,45 +49,53 @@ md5sums=('6549f8ef8ed3419afc1de9f700cea178'
prepare() {
cd "${pkgname}-${pkgver}"
- # Fix faust2 compilation on llvm 3.9.0
- patch -Np1 < "${srcdir}/faust-accept-clang-390.patch"
+ msg2 "Fixing faust2 compilation on llvm 3.9.0"
+ patch -Nsp1 < "${srcdir}/faust-accept-clang-390.patch"
- # Fix QT_QPA_PLATFORM_PLUGIN_PATH problem
- patch -Np1 < "${srcdir}/dont-empty-qt-library-paths.patch"
+ msg2 "Fixing QT_QPA_PLATFORM_PLUGIN_PATH problem"
+ patch -Nsp1 < "${srcdir}/dont-empty-qt-library-paths.patch"
# Some parts of JUCE that Radium uses depend on unstandardized behaviour
# specific to GCC5, so they don't compile with Arch's regular GCC6 and we
# have to switch back manually
- patch -Np1 < "${srcdir}/use-gcc5-for-pluginhost.patch"
+ msg2 "Switching pluginhost build to GCC 5"
+ patch -Nsp1 < "${srcdir}/use-gcc5-for-pluginhost.patch"
# Use the VST SDK from steinberg-vst36, so the user doesn't have to
# manually put it into his home directory
- patch -Np1 < "${srcdir}/use-system-vstsdk.patch"
+ msg2 "Switching to system-wide VST SDK"
+ patch -Nsp1 < "${srcdir}/use-system-vstsdk.patch"
}
build() {
cd "${pkgname}-${pkgver}"
+
+ msg2 "Building packages"
RADIUM_QT_VERSION=5 make packages
+
+ msg2 "Building Radium"
RADIUM_QT_VERSION=5 BUILDTYPE=RELEASE ./build_linux.sh
}
package() {
cd "${pkgname}-${pkgver}"
- mkdir -p "${pkgdir}/opt/radium"
- mkdir -p "${pkgdir}/usr/bin"
- cp -va "bin/." "${pkgdir}/opt/radium/"
- ln -s "/opt/radium/radium" "${pkgdir}/usr/bin/radium"
+ msg2 "Installing Radium core files"
+ install -dm755 "${pkgdir}/opt/radium"
+ # Copy everything from bin except packages
+ find "bin" -mindepth 1 -maxdepth 1 -name packages -o -exec cp -a "{}" "${pkgdir}/opt/radium/" \;
- # Remove objects created during packages compilation.
- rm -rf "${pkgdir}/opt/radium/packages"
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/opt/radium/radium_linux.bin" "${pkgdir}/usr/bin/radium"
- # Restore s7 sources - needed to make the Scheme parts of Radium work
- mkdir -p "${pkgdir}/opt/radium/packages"
- tar -xvf "bin/packages/s7.tar.gz" -C "${pkgdir}/opt/radium/packages" \
+ # Needed to make the Scheme parts of Radium work
+ msg2 "Installing s7 sources"
+ install -dm755 "${pkgdir}/opt/radium/packages"
+ tar -xf "bin/packages/s7.tar.gz" -C "${pkgdir}/opt/radium/packages" \
--no-same-owner --no-same-permissions --wildcards '*.scm'
- # Restore Faust GUI styles - Radium will complain if these are missing
+ # Radium will complain if these are missing
+ msg2 "Installing Faust GUI styles"
install -Dm644 -t "${pkgdir}/opt/radium/packages/faust2/architecture/faust/gui/Styles" \
"bin/packages/faust2/architecture/faust/gui/Styles/"*".qss"
}