summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05b4953a452d..710d637dd58e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Zachary Lund <admin@computerquip.com>
+# Maintainer: Ilya Terentyev <bacondropped@gmail.com>
+# Contributor: Zachary Lund <admin@computerquip.com>
# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
# Contributor: Michael P <ptchinster@archlinux.us>
# Contributor: Roberto Alsina <ralsina@kde.org>
@@ -7,17 +8,17 @@
# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=ragel-dev
-pkgver=7.0.0.5
+pkgver=7.0.0.9
pkgrel=1
pkgdesc="Compiles finite state machines from regular languages into executable C, C++, Objective-C, C#, ASM, D, Go, Java, Ruby, OCaml, Crack, Rust or Julia code."
arch=('i686' 'x86_64')
url="http://www.complang.org/ragel/"
license=('GPL')
-makedepends=('ragel>=6.9' 'kelbt')
+makedepends=('colm-dev>=0.13' 'kelbt')
depends=('gcc-libs')
conflicts=('ragel')
-source=("http://www.colm.net/files/ragel/ragel-$pkgver.tar.gz")
-md5sums=('d6ef02f4947175ae15813ca5495c252e')
+source=("https://www.colm.net/files/ragel/ragel-$pkgver.tar.gz")
+md5sums=('29a4d8ced2f229966317d123a2d5af8a')
build() {
cd "$srcdir/ragel-$pkgver"
@@ -31,4 +32,4 @@ package() {
make DESTDIR="$pkgdir/" install
install -m0644 -D ragel.vim "$pkgdir"/usr/share/vim/vimfiles/syntax/ragel.vim
-} \ No newline at end of file
+}