summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffa4825a06e7..e646585966ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=randomx
_name=RandomX
pkgver=1.1.10
-pkgrel=1
+pkgrel=2
pkgdesc="RandomX: The proof of work algorithm based on random code execution"
arch=('x86_64')
url="https://github.com/tevador/RandomX"
@@ -17,13 +17,15 @@ _blddir=build
prepare() {
cd "$srcdir/${_name}-${pkgver}"
patch -p1 -i ../include-cstdint.patch
+
+ mkdir -p ${_blddir}
+ cd ${_blddir}
+ cmake ..
}
build() {
cd "$srcdir/${_name}-${pkgver}"
- mkdir ${_blddir}
cd ${_blddir}
- cmake ..
make
}