summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6be061b4793
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: VirtualTam <virtualtam@flibidi.net>
+pkgname=raul-git
+pkgver=2901a1a
+pkgrel=1
+pkgdesc="Realtime Audio Utility Library aimed at audio and musical applications"
+arch=(any)
+url="http://drobilla.net/software/raul/"
+license=('GPL3')
+depends=('glib2')
+makedepends=('boost' 'git' 'python')
+provides=('raul')
+conflicts=('raul')
+_gitname="raul"
+source=(git+http://git.drobilla.net/${_gitname}.git)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ${_gitname}
+ git describe --long --tags --always | sed 's/^release.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build(){
+ cd ${_gitname}
+ python waf configure --prefix="/usr"
+ python waf build ${MAKEFLAGS}
+}
+
+package() {
+ cd ${_gitname}
+ python waf install --destdir=${pkgdir}
+}