summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 474c3f3ff232..31c3f687a002 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Jan Cholasta <grubber at grubber cz>
+# Maintainer: Mitch Richters <mjr4077au at gmail com>
+# Contributor: Jan Cholasta <grubber at grubber cz>
pkgname=raze-git
-pkgver=1.4pre+1256+g3c54495c5
-pkgrel=2
+pkgver=1.6pre+2012+g003382654
+pkgrel=1
pkgdesc='Build engine port backed by GZDoom tech (git version)'
arch=('x86_64')
url='https://github.com/coelckers/Raze'
@@ -24,10 +25,8 @@ optdepends=('gxmessage: crash dialog (GNOME)'
provides=('raze')
conflicts=('raze')
source=("Raze::git+https://github.com/coelckers/Raze"
- '0001-Fix-file-paths.patch'
'raze.desktop')
sha256sums=('SKIP'
- 'd8960cba3a0596a6e52072b9bd8f38e92d51be0315fcb53f3cb9c72da4e87081'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
pkgver() {
@@ -35,11 +34,6 @@ pkgver() {
git describe --tags | tr - +
}
-prepare() {
- cd Raze
- patch -i "$srcdir"/0001-Fix-file-paths.patch -p 1
-}
-
build() {
cd Raze
mkdir -p build
@@ -47,14 +41,16 @@ build() {
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_CXX_FLAGS="${CXXFLAGS} -ffile-prefix-map=\"$PWD\"=." \
-D DYN_GTK=OFF \
- -D DYN_OPENAL=OFF
+ -D DYN_OPENAL=OFF \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D SYSTEMINSTALL=ON
make -C build
}
package() {
cd Raze
install build/raze -t "$pkgdir"/usr/bin -D
- install build/raze.pk3 -t "$pkgdir"/usr/lib/raze -D -m 644
+ install build/raze.pk3 -t "$pkgdir"/usr/share/raze -D -m 644
desktop-file-install "$srcdir"/raze.desktop --dir="$pkgdir"/usr/share/applications
install source/platform/posix/game.xpm "$pkgdir"/usr/share/icons/hicolor/256x256/apps/raze.xpm -D -m 644
install package/common/buildlic.txt -t "$pkgdir"/usr/share/licenses/$pkgname -D -m 644