summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53cbe61d364c..148b734bca54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
pkgname=rdkit
_pkgname=RDKit
pkgver=2015_09_2
-pkgrel=1
+pkgrel=2
pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
arch=("i686" "x86_64")
url="http://rdkit.org/"
license=('New BSD License')
depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python2' 'python2-numpy' 'sqlite3' )
-source=(https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz )
-md5sums=('889fc8bda9d59ce3b72bf6252c630287')
+source=("https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz" "http://www.inchi-trust.org/download/104/INCHI-1-API.zip")
+md5sums=('889fc8bda9d59ce3b72bf6252c630287' '8447bf108af12fe66eecba41bbc89918')
provides=('rdkit')
build() {
cd ${srcdir}
mkdir build
+ cp INCHI-1-API/INCHI_API/inchi_dll/* ${pkgname}-Release_${pkgver}/External/INCHI-API/
cd build
cmake ../${pkgname}-Release_${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
@@ -22,7 +23,8 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DPYTHON_LIBRARY=/usr/lib/python2.7/config/libpython2.7.so \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7/ \
- -DPYTHON_EXECUTABLE=/usr/bin/python2
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DRDK_BUILD_INCHI_SUPPORT=ON
make
}