summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a02aaf986260..a655ed0ef9f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: farwayer <farwayer@gmail.com>
pkgname=react-native-cli
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="The React Native CLI tools"
arch=(any)
url="http://facebook.github.io/react-native/"
license=('BSD-3-Clause')
depends=('nodejs')
makedepends=('npm')
+options=('!emptydirs')
package() {
- npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
+ npm install -g --prefix "$pkgdir/usr" --cache "$srcdir/npm-cache" $pkgname@$pkgver
+ find "$pkgdir/usr" -type d -exec chmod 755 {} +
}