summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17ecd8e1f70f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Michael Armbruster <michael@armbrust.me>
+pkgname=recordurbate
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="A Bot to automatically record Chaturbate live streams"
+url="https://github.com/maki-chan/Recordurbate"
+arch=('any')
+license=('GPL3')
+depends=('python' 'youtube-dl' 'ffmpeg')
+makedepends=('git')
+source=("git+https://github.com/maki-chan/Recordurbate.git#tag=1.2.0")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "Recordurbate"
+ git describe --tags --abbrev=0 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "Recordurbate"
+ python setup.py build
+}
+
+package() {
+ cd "Recordurbate"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}