summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de33efce4336..3d09dc2c9bd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=redshift-qt
pkgname=$_pkgname-git
pkgver=0.6.r0.g6724a9f
-pkgrel=1
+pkgrel=2
pkgdesc="redshift-gtk rewrite with C++/Qt (latest commit)"
arch=('x86_64' 'i686')
url="https://github.com/Chemrat/redshift-qt"
@@ -13,16 +13,18 @@ depends=('qt5-base' 'redshift')
makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+$url.git"
- "$_pkgname.desktop")
-md5sums=('SKIP'
- '9ef24b824bcfb46dbd951074af074772')
+source=("git+$url.git")
+md5sums=('SKIP')
pkgver() {
cd $_pkgname
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ sed -i -E "s|Name=Redshift|Name=Redshift Qt|g" $_pkgname/data/$_pkgname.desktop
+}
+
build() {
cd $_pkgname
qmake $_pkgname.pro
@@ -30,8 +32,8 @@ build() {
}
package() {
- install -Dm644 $_pkgname.desktop -t "$pkgdir/usr/share/applications"
cd $_pkgname
+ install -Dm644 data/$_pkgname.desktop -t "$pkgdir/usr/share/applications"
install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$_pkgname"
install -Dm755 $_pkgname -t "$pkgdir/usr/bin"
}